Dial Plan Issue with MPK's Model GRP2616


Hello, I have “no dial plan rules match error” when using the 8 MPK’s on the lower right of the phone.

It only dials out when numbers are formatted 01792XXXXXX

If I use 01792 XXXXXX it says no dial plan matched. How do I set Dial Plan for MPK’s ?

Local phone book entry’s DO allow 01792 XXXXXX Checking Box “bypass dial plan for MPK” has no effect

How do I create a Dial Plan for those 8 MPK’s that will allow for spaces after the first 5 numbers?

Thank you all in advance
Regards Tony


You need to look at it as to how you would otherwise manually dial the same number. How does one go about manually dialing a space? This is why skip the dial plan aspect still creates an error as there provider likely does not understand what a space is. The outbound number format must match that which the provider requires in order to pass the call along.

Do I take it that the number with a space is one that was stored from a received call and how the CID was displayed? Or, is this a number that is being pulled in from some other source?

Rightfully or wrongly, the expectation is that the source number is formatted correctly to begin with. Depending on the source, folks can input various digits or other to make the number more human friendly to read, 1-956-555-1212, 1.956.555.1212, etc., but these are not something that the provider can deal with so the call fails.

Depending upon what is being used for the source, if a PBX or provider, perhaps there is a provision to modify the incoming by looking at the request line rather than the TO. Perhaps there is a modification to the inbound string format that can be programmed into the inbound.

If a independent source, perhaps a script to create an XML file which would contain the needed number without the space along with the associated name. If names are to be included as a look-up then the number being presented to the phone must match exactly to pull the name.


Thank you very much for the in-depth reply. The dialled numbers were sourced from the local phone directory. Some had spaces when I originally entered them in, Some did not. The local phone directory always dialled the number irrespective if there was a space or not. The problem came when checking the “copy local directory to MPK” option. I guess I will just enter the MPKs manually with no spaces.