Dial Plan for Removing Spaces

ip-communications

#1

Hi,
I’m using the following dial plan:

{ x+ | <+91=>x+ | +xx+| x+ | **xxx+ }

  1. We re in India and to remove +91 I added the above.
  2. My major problem is that phones both android and apple save numbers with spaces. How do I remove the spaces??
  3. How do I get numbers to dial with #. Eg: MY asterisk is configured like: #60 --> ??

Is my above dialplan correct or do I need to make corrections for removing +91 or 0 at the beginning??

Any help would be appreciated.

Thanks


#2

Hi pranavjairam,

Thanks for posting on the forum. Kindly please find my answers below:

  1. To exclude certain digits please use the “^” in dial plan. You can also replace the leading digits in dialplan please try the following : {<+=00>x+}

  2. Under Call Settings, please set “Use # as Dial Key” to No. This will enable the “#” key to be included in the dialing string

For more information, you can refer to the manual here http://www.grandstream.com/sites/default/files/Resources/GS_Wave_User_Manual_1.0.2.5.pdf (page 56 & 57)

Kindly please let me know if you have further questions.

Regards


#3

Thanks for your reply. This doesn’t help me a bit. I’ve tried all the suggestions. Could you please help me by giving the dial plan itself??

Thanks


#4

Hi,
I have the same issue. On my Android phone my numbers are stored as kind of
+49 (987) 654321

The App cannot dial these numbers. So how should a dialplan look like to reformat these numbers to
0987654321

Thanks.


#5

Hi,
I achieved to replace +49 by 0 with this dialplan:

{<\+49=0>x+}

But all my phone numbers in Android address book are stored as +49 (987) 654321. I cannot replace the brackets with any kind of dialplan, because the large X does not work and
"\("
also gets thrown out.

I cannot believe that Grandstream published an app which is not able to use standard Android/Outlook-stored phone numbers. Any other VoIP-app is able to. And this issue is known since years now!


#6

Hi Magra,

{<+49=0>x+}

works for me, too. Although in my case I don’t have a problem with the “+49”. In my case even the brackets within the contacts are being ignored successfully.

The only problem I have, are actually the spaces within the stored phone numbers.

How can replace the spaces with “nothing”?!?

I also can’t believe that in the year 2018 an app on an android OS has a problem dialing a contact with “+”, spaces and brackets within the number!


#7

Spaces and brackets are a problem for me. And also the other way round on incomings calls there is no matching to the address book.

I don’t understand why Grandstream is not able or not willing to fix this. I opened a ticket more then 6 months ago, but nothing happens. With these issues solved GS Wave would be the best VoIP-App in Playstore.


#8

I found a solution to my problem. And that solution also explains why brackets weren’t an issue in my case.

I have a GXV3240.

Under

Account (Account #) | Call Settings | Dialplan

I added

<+49=0>x+

so my dialplan now looks like:

{ <+49=0>x+ | x+ | +x+ | *x+ | xxx+ | x+*x+*x+*x+ | x+*x+*x+*x+#x+ }

As said before, I couldn’t find a way to ignore/exclude/replace the spaces within the phone numbers.

Today I coincidentally found the option

Filter Characters

under

Advanced Settings | Call Features

The default value was (in my case):

[()-]

All I did was to add a space at the end:

[()- ]

Now brackets, “-” and spaces are being filtered successfully!


#9

Sadly this is no solution for the Wave App.