Destination Directory for Schedule Backup


#1

I am trying to schedule a backup to a sftp server and am having problem with the Destination Directory format. I can connect to the the sftp server, when I enter the Destination Directory, I get Invalid Format. The remote directory should be /d:/Software/Phone/Backup. Can someone help me out on how this should be formatted?

Model: UCM6204 V1.5B
Firmware: 1.019.27


#2

I don’t want to be wrong but it is “d:” that probably he doesn’t like it, try to create an easy path, then customize it according to the possibilities

p.s.: I had tried it and it worked, but the path if I remember well I set it on the server side SFTP and not on the client side


#3

The d: is because it is connecting to OpenSSH on a Windows Server. d: representing the d drive on the server. I have tried the format with double quotes, single quotes, plain. It says invalid format on just about everything. Could you paste the exact path you typed in?


#4

Since the UCM side is embedded Linux, try:

d:\/Software\/Phone\/Backup


#5

Tried d:/Software/Phone/Backup with no success.


#6

Sorry, I ment I tried d:/Software/Phone/Backup with no success


#7

I have never used this facility, but your use of a drive letter seems wrong. From my other experiences with FTP, you set the destination drive and directory in the server itself. Then the user specifies the patch from the root.

Does this make any sense with your SFTP setup?


#8

Here is my setup in the UCM -

I used this on a remote system where I was having it come across a VPN so I could get the wireshark captures in my Windows machine.


#9

Users/Larry… is assuming the C drive, or wherever the SFTP server wants to put things by default.

You have two options: 1) Try using backslashes to escape the forward slashes as I suggest. 2) Set up SFTP so that there is an alias for where you want to store things and use the alias.

Anything else is just wasting time. :slight_smile:


#10

That is true about c being it, only thing I have on that system.