[DEFECTIVE HARDWARE] GSC3570 - touchscreen does not work


#1

I just received the GSC3570 Beta unit. I tried powering it via USB, and POE. In both cases it powers up and gets to the main screen with clock widget and 6 other buttons, but I am not able to swipe left or right to change screens.

Eventually it goes into screensaver mode, and touching the screen does not get it out of that mode.

If I touch the capacitive “home button” below the screen, then the screen saver goes off and the device goes back to the home screen.

I presume this is defective hardware?


#2

We received ours Friday while we were closed. Just unpacked it and plugged it in for the first time. Will let you know what we see…


#3

Sorry, Eric. Ours came up (quickly) to a functioning screen complete with touch capabilities and a DHCP IP address. Connecting to web server works fine.*

*But only from Chrome, not Firefox. We’ll be submitting that as a bug on its own.


#4

I got a cert error in Firefox but it did load ok. Is that what you were talking about?


#5

No. I’m not going to continue this conversation here, because we have another bug report open at https://forums.grandstream.com/t/web-interface-not-working-in-firefox/39767


#6

sounds like touchscreen HW issue, could you contact the insider portal, our marketing team who arranged the shipping should take care of this. sorry for the inconvenience.


#7

Hey Shawn. Do you want me to … open a ticket on the insider portal, or do something else?


#8

yes, please file a ticket on the insider portal, I’m not sure if we still have enough unit to replace your defective one, but please let them know. And I will tell the HW team directly see if they need your device to analyze the cause. Thank you!


#9

I had a similar experience. It turns out the touchscreen is locked out until a reboot if you leave the protective plastic film attached at powerup. We installed the unit, it powered up, then we removed the film and touch did not work. We power cycled the unit without the film attached and it works fine.
We did have problems with DHCP over ethernet. I switched to WiFi for testing and that did pull an address. I’ve not explored the DHCP problem in depth.


#10

I removed the film before booting. I also tried rebooting multiple times.


#11

@andrewsvet. As we wrote earlier:

This was without removing protective film or doing anything other than literally plugging in a PoE cable and then checking to see what IP address the device was assigned by going to the network settings page. So our film is still attached.

Are you saying that if we now remove the protective film, it will lock out our screen?

Regardless, @eric.tamme device seems to be borked and deserves factory love.


#12

Maybe our experience was coincidental. The device booted with an inoperable touch display. I removed the film and it still didn’t work (clock was advancing so the device wasn’t completed locked). After removing the film and rebooting the device, the touch display then started working. That may have been a coincidence about the film and maybe the reboot was all that was needed. I’ve rebooted a few times now and not had any problems with the touch display.


#13

Interesting. We’ve booted once, and had no problems. We may have accidentally reset our PoE switch and caused it to reboot unintentionally, but still no problems.


#14

Hi Eric,
Did you ship the defective unit to us already? Our HW engineer is asking me about it. He is about to take a lonhvacation. Thanks!


#15

yes i shipped it back


#16

Thank you Eric!