Debug SS7 connection


Hello all,

Yesterday we have tried to connect a GXW4502 with a PBX using SS7. Once we plugged the wire on the service port1, when we checked the Dashboard it changed the label(not the colour) from ‘Red alarm’ to ‘Signal link down’. It didn’t looked to us an expected or operational response, so we tried to overcome the situation by tunning some config parameters but we couldn’t change it.
Then, I recoverd logs from SS7 interface, analized them but still I couldn’t find clues for the diagnostics:

  • Interrupts.txt doesn’t show errors
  • nvram.txt just describe component versions
  • sysinfo.txt output contains many more technical details that I can’t properly evaluate as error reporting than final line
GXW450X*CLI>ss7 show linkset 1
Invalid linkset $i.  Should be a number 1 to 32
  • Finally, the pcap trace only contains FISU messages with same contain.

I would appreciate if you could please advice me on further steps. To me, current situation doesn’t seem a phisical connection issue but some configuration problem but currently available information doesn’t allow me to see the cause.

Thank you very much.



Update: I wasn’t allow to upload the logs directly, but I think I can share parts in text mode if needed.
Thanks again!


When i worked on troubleshooting PRI (using SS7) on the UCM6510, the call structure on SS7 is somewhat similar to a SIP ladder.
If the signal link down is the primary indicator on the dashboard, i would look at the primary signalling settings.
On the primary link page, check that these settings match what the CO requires:

and then also on the advanced settings page - the switch type:

Getting the clock and primary setup working so it meshes with what your telco is set to is your first goal to get the link on the dashboard blue.
After that its just routes…