Cut call for 32 seconds with remote extensions


#1

Hello
I have an ucm6202 but it happens that when you enter a call through a sip trunk of telmex the call is cut at 32 seconds, this happens when enabling nat for remote extensions

hola
tengo una ucm6202 pero sucede que cuando ingresa una llamada por una troncal sip de telmex se corta la llamada a los 32 segundos, esto pasa al habilitar la nat para las extenciones remotas


#2

You have a NAT issue.

When you make a SIP call, there is an exchange of messages to establish the call and each request is usually answered with a response. When the initial INVITE is sent, it starts a timer (T1) which is used by the device that sent the INVITE to wait for an ACK from the receiving device at which point if received, the call is considered established and the call will proceed normally. If the ACK is not seen, then at the end of T1, timer B kicks in and disconnects the call and this time is 32 seconds.

This is usually because one end is telling the other end to use its private IP rather than its public IP and as a result, the ACK that is sent is never seen and the call is disconnected.

Presumably you have set PBX settings, SIP settings, External IP. Host to have the public IP or public FQDN and you have checked the SDP box as well as having included the local LAN into the settings as the bottom of the page?

Additionally, at the remote site/phones, you have set the public IP in the NAT IP area (phone make and model unknown) so that when they communicate they are telling the PBX what public IP to use? There may be more to it than this as we do not know anything about the remote - how many extension behind a firewall, dynamic or static IP, port forwarding, SIP ALG, etc.

Check the UCM first and then advise on the other remote aspects with more detail.


#3

I’m basically repeating @lpneblett
These are the things I verify when I have this issue

Many people will ignore port forwards because the system seems to work sometimes without them.

Be sure you have forwarded ports in your firewall that accommodate the calls setup and RTP streams as well as making sure SIP ALG is off so it doesn’t rewrite packets.

Check the following:
-port forwards(this is with default settings on the UCM)
UDP 5060 to UCM (can be locked down to just SIP Provider IPs)
UDP 10000-20000 to UCM (must be open to all)

SIP ALG must be off

On the UCM
PBX-SIP-NAT External Host should have static IP or dynamic DNS address in it (this tells the SIP Provider what address to respond to)
Use IP address in SDP should be checked

-Keep in mind best practice is to change the 5060 port to something else as well as narrowing down the RTP ports to a much smaller amount.


#4

@lstutesman, use in SDP n you mean better activate it or better not activate it?
However, I would not open all RTP ports to follow the same rules as the 5060.


#5

Better to have the box checked


#6

ok thank you :slight_smile: