Can't use dummy extension for external (cell phone) number


#1

I have tried and tried to set up a dummy extension that can call an external number, but with no luck.

What I want/need to do is have an incoming call ring a ring group of local extensions, then, if not answered, ring a cell phone. I have read threads here that “follow-me” does not work with ring groups and external numbers. And I have read that an external number cannot be used in a ring group.
But in this thread https://forums.grandstream.com/t/ucm-6202-ring-group-issue/32849/11
the issue was apparently solved by setting up a dummy extension which uses “follow me.”

Using the “follow me” feature of a dummy extension you can ring multiple “external numbers” simultaneously or in order, just as you expect from a ring group.

My problem is I can’t even successfully setup a dummy extension with “follow me” as the destination.


When I dial the dummy extension from any valid extension I get:
“Please wait while I try to locate the person you are calling”
then
“The number you dialed is incorrect”.
Why? I have the same setup on real extensions that work correctly and dial out to the cell number. But with the dummy extension it does not. Why not?

Any help would be very much appreciated.

My specs:
Model: UCM6202
FW: 1.0.20.23


#2

you have to use internal LDAP to add external numbers


#3

Thanks for your reply.

There seems to be conflicting info on that. Different forum posts say different things.

Anyway, I did try using an internal LDAP. I created an LDAP phonebook with only one number in it; the cell number I want to dial. I added that to the ring group, though I only want to call the cell number if the ring group does not pick up. Nevertheless, adding that LDAP phonebook to the ring group does not ring the cell phone even though all lines are set to ring simultaneously.

I have looked at the user manual to see how to use LDAP in this case, but there is very little information. Under ring group configuration it says:

“Select available remote users from the left side to the ring group member list on the right side. Click on (up/down arrows) to arrange order. Note: LDAP Sync must be enabled first.”

I can’t see where to enable LDAP sync. It appears to only be available to Peer Trunk not Register Sip Trunk which is what I have. I don’t know how to use LDAP to do what I need.

Any further thought?


#4

Instead of a ring group, use a call queue. Set the timeout destination to external number. It can ring the agents the desired time, then send the call to the outside number.

I’m off ring groups(thanks to smart people on this forum), even for the simplest instance, call queues give you so many more options.


#5

synchronization is only needed if you put 2 or + UCM in PEER between them


#6

@damiano70

synchronization is only needed if you put 2 or + UCM in PEER between them

That’s not the case for me. Still it doesn’t work.

@gregstahl

Instead of a ring group, use a call queue. Set the timeout destination to external number. It can ring the agents the desired time, then send the call to the outside number.

I have tried your call queue suggestion but I still get “The number you dialed is incorrect” message at timeout with the destination the external (cell phone) number.

Is this somehow related to my Outbound route and “Enable Filter on Source Caller ID?”

I have heard 3 or 4 suggestions for how to accomplish what I need, but none of the answers seems to work for me. Something must be causing all of the solutions to fail. That’s what makes me wonder about my Outbound routing. At the simplest level, shouldn’t I be able to dial, from a regular extension, a dummy extension which gets forwarded to an external (mobile) number? Why can’t I even do that? I can dial a speed dial to that number without any problems.

That brings me back to damiano70’s suggestion of LDAP. But I can’t get that to dial! What is preventing me from achieving any of the solutions?

Thanks for your continued help.


#7

Get rid of source caller limitation and test, then you will know.


#8

Yes, that is indeed the culprit. But I need to have calls out assigned to the correct accounts for billing purposes. Without filtering on Source Caller ID how do insure that the correct trunk is used? In fact, I have tested this and all outbound calls that go to the external (mobile) number are going out on only the trunk that doesn’t have Source Caller ID. Can this be solved?


#9

In addition to the wrong outbound trunk being used, I also don’t get the original CID or CName so I know who is calling. Instead I get the name the trunk is assigned to which is not correct since it’s not the correct trunk.


#10

I have found another post that seems to address this same issue, but I don’t know if it was ever resolved.

https://forums.grandstream.com/t/trunk-selection-and-call-forwarding-to-external-numbers/35334/4

Both @damiano70 and @lpneblett suggest an outbound route for each SIP trunk - which I already have - but it’s not clear to me how I would set something like this up, specifically regarding the prepend/strip. Any additional help would be appreciated.


#11

You can ring external numbers from a RG, just use the LDAP function.

Additionally, it is not clear to me why a dummy extension using follow-me, unless you want to accept/reject the call which if rejected, presumably sends the call back to the dummy extension’s voicemail.

To force a route, in the external number prepend a digit such that the number to be dialed is 918885551212 then, set a rule for the desired trunk such that the outbound rule reads 91NXXNXXXXXX and then strip 1. This will remove the “9” from the dial string such that the provider will get a correct string that they can process. Use whatever prepend number or group of numbers you want and just strip them out before sending. Do not use source ID.

Additionally, in the trunk settings check keep original CID.


#12

@lpneblett,

Wow, you’ve given me a lot of great info. Thanks for the detailed description of how/why to use number prepend/strip.

You’re right about the dummy extension. As is often the case, I read as many forum posts looking for solutions and was grasping at different concept. I pretty much dismissed the dummy extension idea a while back based on what you’ve told me and what I’ve been experimenting with. Unfortunately the heading of the post was where my thinking was at the time.

I need some time to experiment with your ideas. If I have any further questions I’ll post them.

Thanks again for making the concepts clear, and for your help.


#13

In Extension, go to in feature, then use ring simultaneously, it’s working


#14

@lpneblett,

Thanks very much for your help. Your suggestion for creating a new outbound rule with prepend/strip tied to a specific trunk is now working as expected.


#15

Glad it worked. Closing the thread.