Can't upload OpenVPN Certificate on GXP1625 FW Version 1.0.4.152


#1

Hello,

I’ve updated the GXP1625 to the latest firmware update Version 1.0.4.152

But now i have a major issue, there is a bug, when i try to upload a 5kb .CRT file into the “OpenVPN® Certificate” i’m getting an error File size is too big. Please try again.

This error is only in the latest firmware i can confirm all previous firmware didn’t had this issue, My question is how i fix, is there another way to upload the crt file to the phone ?? or maybe is there a possible way to downgrade to the previous firmware

Thanks!

grands|690x450


#2

I thin k it is 4k max now, reported it already afair.


#3

I have the same problem.

I try to downgrade the firmware without successful.
Any possible solution?


#4

Hello SNET

Yes this problem is very annoying, but i’ve downgrade to the previous Firmware 1.0.4.140
and and the problem is gone, i had to reset the devices to factory reset and then reconfigure the OpenVPN Part and it work

Here how it worked for me
Download the FW from here
(http://firmware.grandstream.com/Release_GXP16xx_1.0.4.140.zip)

Unzip the file and upload the .BIN to your own server/or local address

Set the Firmware Server Path to HTTP also the Config Server Path to HTTP and place the address to the folder where you have the gxp1600fw.bin file for example, somewebsite.com/fw/ no http on front of the url,

Reboot the phone it would pickup the newer firmware, and now you can setup the OpenVPN with no issue, however for it didn’t worked on the first attempt i had to factory reset and reconfigure everything again

Good luck


#5

Same problem here with latest firmware. Release_GXP16xx_1.0.4.152.zip

I did not wanted to do a firmware downgrade so I try removing from the certificate anything but this lines and the content between…

-----BEGIN CERTIFICATE-----

-----END CERTIFICATE-----

File size is reduced to 2K and then it the upload was successful.

When Openssl generates the certificates, it includes a lot of data (Information already encrypted on the certificate), but apparently, is not necessary.

Telephone ( GXP1628 ) is now working on OpenVPN and latest firmware…

Anyways, it seems a nonsense restriction… The should remove it in next firmware…


#6

I agree with you, although I think it’s a problem hw, so not solvable.
Can I please ask you the exact procedure you use to set up OpenVPN on the GXP1625 phone?


#7

Hi Damiano, the problem here was the certificates being to big.I just removed everything that is not needed.

The certifcates are generated like this…

Text-text-text
Text-text-text
Text-text-text
-----BEGIN CERTIFICATE-----
38728nhd823i1…
-----END CERTIFICATE-----

but the need part is only this…

-----BEGIN CERTIFICATE-----
38728nhd823i1…
-----END CERTIFICATE-----

The rest of the options for the GXP1625, just need to be the same as the openVPN server that you are conecting to.
I Used AES-256 and Comp-lzo, because that is what my server is using (community edition openvpn on windows)


#8

hi @avalenzuela,
I’m writing to you in PM