Can't Register Remote GXP2130 Extension to UCM6202


#1

First, I am not a professional installer. I own a small eldercare company and am replacing a Talkswitch 244VS system with a UCM. I installed both systems myself. My experience is limited and I don’t know all the acronyms & jargon. Please bear with me.

  1. Both the UCM & remote phone are behind Netgear R7000 routers with static IPs.
  2. The internal IPs of the UCM & GXP are “reserved” in the routers.
  3. Port forwarding on the local router points 5060 & 10000-20000 to the UCM internal IP.
  4. The same ports on the remote router point to the GXP internal IP.
  5. NAT SIP ALG is disabled on both routers.

The SIP setting on the UCM is set to the static IP of the UCM router. The UDP, TCP & TLS ports are set to 5060, 5060 & 5061 respectively. The local network address is set to the internal IP of the UCM. NAT is enabled on the extension.

Per the Grandstream HelpDesk rep’s suggestion, I:

  1. connected the GXP to the “local” UCM router and auto discovered.
  2. then connected the GXP to the “remote” router.
  3. used the GUI to set the SIP server (under Account 1) to the UCM router’s static IP.
  4. confirmed the SIP & Authenticate IDs to be the same extension as in the UCM.
  5. then saved, applied, provisioned & rebooted.

The phone will not register. Sorry for the long, involved explanation, but, can anyone help?


#2

How many phones do you have remotely? If more than one, DO NOT forward ports.

The 5060 and RTP ports should only be forwarded in the UCM side.

Also, on the UCM, under “PBX Settings -> SIP Settings -> NAT”, verify that your external host is the static IP and that “Use IP in SDP” is checked.


#3

Wow, thanks for the quick response! I’ve done/checked all your recommendations. NOTE: I will be using more than one remote phone, but, just one right now.

What triggers the phone to attempt to register?


#4

When using one or more phone remotely, the configuration stated above will work no problem. I had 2 remote workers and both didn’t have any trouble.

To trigger a register, either wait for the registration expiration (between 5 and 60min depending on config) or reboot the phones. Also, saving SIP config on phone’s web UI will trigger a register.

By the way, I am a lot on this forum so don’t hesitate!


#5

Re-booted…still no luck


#6

Can you provide me with your basic config used for the phones? And the config for your extensions?

You also need NAT enabled under the extension, verify that!


#7

Basic Settings

TEL URI = Disabled
SIP Registration = Yes
Unregister on Reboot = No
Register Expiration = 60
Subscribe Expiration = 60
Reregister before Expiration = 0
Enable OPTIONS Keep Alive = No
OPTIONS Keep Alive Interval = 30
OPTIONS Keep Alive Max Lost = 3
Local SIP Port = 5060
SIP Registration Failure Retry Wait Time = 20
SIP T1 Timeout = 0.5 sec
SIP T2 Timeout = 4 sec
Switch Backup Proxy on No Response = No
SIP Transport = UDP
SIP Listening Mode = Transport Only
SIP URI Scheme When Using TLS = sips
Use Actual Ephemeral Port in Contact with TCP/TLS = No
Outbound Proxy Mode = in route
Support SIP Instance ID = Yes
SUBSCRIBE for MWI = No
SUBSCRIBE for Registration = No
Enable 100rel = No
Callee ID Display = Auto
Caller ID Display = Auto
Add Auth Header On Initial REGISTER = No
Allow SIP Reset = No
Ignore Alert-Info header = No


#8

Did you set the NAT settings on phones to STUN?


#9

No, I haven’t


#10

Where is that located?


#11

Under the phone Web UI:

Accounts -> Network Settings -> NAT Settings -> NAT Traversal

Set it to STUN if not setted.


#12

No change. Should there be any value for the “Stun Server”?


#13

Normally you can use “stun.ipvideotalk.com” but I don’t remember if it still works.


#14

I tried it, but, still nothing. I know the phone is at least getting out to the internet because the display has the correct time and weather


#15

Verify that your port forwarding is working on the UCM side and verify you have the latest firmware on both.

At this point, it seems like a firewall issue as your config is correct.


#16

Both routers are up to date. Ports 5060 & 10000-20000 are pointed to the UCM IP.


#17

At this point, I would suggest doing a factory reset, provisioning using ZeroConfig (local only, maybe use a temp VPN?) and then change the SIP adresse to WAN IP.

Pass that, it’s hard to diagnose via a forum.


#18

I have another new phone (same model). I may give that a try. Could be I am dealing with a defective one. Thanks so much for the help. It is truly appreciated.


#19

Yes, try another one! Always factory reset before configuring tho, to prevent config issues.

It may be a defect but if it is brand new, just call your distributor and get a new one under warranty.


#20

as per my knowledge no need of point 4 The same ports on the remote router point to the GXP internal IP. disable firewall in remote location router because firewall except traffic on port 80, the HTTP,Https port. and try to register on softphone so will get clear about it is phone setting problem or remote location router setting problem .