Can't get phones to pick up ring tones


#1

Good afternoon. The ringtone assignment process is very straightforward, yet the phones themselves never download the files I tell it. This is both via visual inspection (not seeing the file names appear in the available ringtone lists of the phones, as well as not hearing them play). These are files that upload manually and work just fine, so clearly the file format is correct. The phones just never pick up the files from GDMS.

This is on both GRP2615 & GXP2170 models (current - as of today’s date - firmware).

Frankly, all we care about is the simplistic logic of creating a “ring1.wav”, “ring2.wav”, “ring3.wav” as additional download attempt logic (or, you know, ring1.mp3, etc.). This would have been relatively simple logic that didn’t require GDMS, and since no one uses those horrible .bin files any longer, it didn’t seem like too much to ask back in 2017 that the default ringtone download logic be expanded to support the newer file formats. So now we’re forced to use GDMS for it, which makes the process more complex, but not the end of the world… But if it doesn’t even work, that of course makes things problematic.

How can this be corrected?


#2

Agree that I wouldn’t need to use GDMS as much if the ring tones were anywhere decent.

Here is the screenshots of the method I use.

  1. Load Ringtones into Resources

  2. Define Ringtones to Ring 1,2 & 3 to Handset Device.

  3. Assign Ring Tones 1,2 or 3 to Handset.

  4. Save and Apply to handset, it should then load the ringtones from Cloud GDMS.


#3

Yup. Like I said, the process appears straightforward but it’s just not working. We tried it two different ways. We pre-loaded in resources so they were available from the endpoint’s resources menu. We also uploaded them new from the endpoint’s resources menu (which ultimately achieves the same thing). Neither are loading. Tried both .wav and .mp3 variants, and both are files that play just fine when manually loaded on the phones. Tested on both a 2615 & 2170, both have the same failure. :frowning:


#4

What phone system are the handsets connected to?

In 3CX, I remove the config location settings so that the SIP server doesn’t over right the settings I put in manually in GDMS.


#5

I’ve even tested before re-pointing to the phone system’s config string - so literally, GDMS only, and they still don’t download. (sigh).


#6

Show me a screen shot of the Device in GDMS.


#7

Here you go. Uploaded, assigned, and called out in the config, but the phone never grabs. Like I said, relatively self-explanatory on the process, just doesn’t seem the process is actually working. :frowning:


#8

Looks fine… Maybe create a case.


#9

That’s what I was thinking at this point, since it seemed like it was set up properly. Didn’t know if there was something I was missing, or if others had experienced.

Thanks.


#10

Dear users,

Thank you all for using GDMS platform! We checked your settings and the caller ID is “Internal”? Could you try to use an extension to replace it and try again? We suspected that this issue was caused since the caller ID is not matched, so that the ringtone will be the default ringtone. You may try to use an extension as the caller ID and try again:

Could you also send a provisioning syslog to us for troubleshooting? Thanks for your testing!

Thank you!


#11

You may want to re-read your own documentation. Grandstream phones not only match CLID, but also Caller-Info headers. Matching works just fine to a header we’re pushing of “internal”, “priority”, and “return”, as long as we select any of the built-in ring tones (which no one likes, hence the ongoing desire to load something decent).

Remember (from above), I know it’s not downloading them, not just because of the lack of proper audio feedback, but also because on the phone, the list of ringtones doesn’t include the files I’m trying to push.


#12

Dear user,

Thank you for your feedback! Could you send your device’s MAC address and provide us the syslog from the device for troubleshooting? We cannot reproduce this issue from our side. You can retest it and capture the syslog from begining, and then once you have assigned the ringtone to the device, stop capturing and send the syslog to us, we can troubleshoot this issue based on your syslog. Thanks for your testing!

Thank you!