Calls coming in are showing anonymous from Analog Trunks



I have configured the UCM6102 to forward calls from 2 analog trunks to a Ring Group (2 phones).

  1. When any call comes in, it shows up on the two phones as Anonymous, so if it is missed, I can’t determine who to call back or which number to call back.

  2. The two analog trunks have been configured to allow outbound calls via Analog Trunk 2 (cheaper call rates), with Failover on Analog Trunk 1. However, When calls come in on the main number Analog Trunk 1, both phones in Ring Group ring simultaneously (good), I answer on Phone 1, and then another call comes in on the same Analog Trunk 1 number, the call appears on my Phone 1 handset requiring me to transfer the call or put on hold etc, is this how it is supposed to work or does this not auto ring on the second Phone 2 in the Ring Group instead? The second incoming on Analog Trunk 1 does not even ring the Phone 2 at all, it comes straight to Phone 1 that is already in a call.

Please help. Thank you very much in advance.


With analog trunks, there is only one call per. Otherwise, it requires a flash hook which the Ucm does not support…at least not yet. The Cid issue may be related to how you have the ucm set to detect, the phones detection settings or the provider is not sending. If in the US set to bell/telecodia.


This may sound like a stupid question but I got burnt by it a few months ago:

Do the incoming analog lines have Caller ID service enabled? We all are spoiled by CID these days and take into assumption that the service is enabled when it is actually an “extra” especially if it’s a 10+ year old phone line.

You may need to plug in an analog phone directly to that phone line to test to see if the caller id occurs. You may become surprised to find out that the issue isn’t the UCM.


make sure you’ve done the ACIM detection in ports config.
make sure you’ve ordered the service for caller ID on both of your analog lines.

if you do NOT pay for caller ID then make sure the use CallerID box is unchecked on the trunk.


I am also facing the same challenge as well as SLA analog trunks though when i configure the SLA trunks and station, i can successfully monitor the trunk being free or busy. Unfortunately, the SLA stations cant call any one even within SLA stations. Non SLA stations can call the SLA station. I wonder why! Help


This is normal behavior for the SLA stations, because:
-The SLA Trunk becomes exclusive for the SLA Stations: the only ones that can make/receive calls through that Trunk are SLA Stations.
-The SLA Stations become exclusive for the Trunk (The SLA stations can only make calls if they will use the SLA Trunk, so they cannot make internal calls (but they can receive them).

A turnaround can be tried if you are willing to make the internal calls using the SLA Station, which is to add another extension (configure another SIP account) on the same IP phone (used as the SLA station), so that you select that Line whenever you want call internally.


I have a client, 4 lines, 1-3 are voice, 4 is fax, they were complaining of random “anonymous” calls, they worked out that the same caller would have caller ID another day… turns out LINE 2 from BELL had no caller ID on it, it used to work, Bell did something and broke it a year later… i worked this out with a $10 phone plugged in to the line and called it from my mobile, so might be worth testing if caller ID works on the line itself.