Calls are choppy when receiving calls on GXP 2170

bug

#1

I have GXP 2170 I am using hosted call center called Zaplee with their sip settings and incoming calls are choppy, callers don’t hear me well at all


#2

It sounds like an Internet issue in that there is jitter (latency) and/or dropped packets. You can try and adjust the jitter buffer some, but if dropped packets it will not recover these.

This is not a phone issue, but either the data needs are not met by your connection (too small a bandwidth), an internal LAN issue, lack of QoS or a combination of any of the aforementioned to include ISP. Given that the issue is observed on both up- and downstream connections, what is the bandwidth?


#3

I have 25MB so my bandwidth is fine. This is only happening with incoming calls though


#4

Download is 25 Mbit and Upload I have is 10MBit. I really need to find out what is causing this and correct it.


#5

Codec preference.


#6

You can find out what codecs are preferred by your provider and adjust the phone to only use same and delete the others. As outbound calls are apparently OK, then it seems that the phone is using what the provider likes and it may be worthwhile seeing if that is g729, When you make a call, then you can see what the phone likes and what the provider is accepting and if not the same, then adjust the order of the codecs in the phone.

In other words the provider may be sending down g729 and g711u and the phone is accepting the first one seen. Conversely, when making a call perhaps the phone is sending g711u and g729 and the provider is accepting the fist one seen. Adjust the phone such that the phone sends g729 and then g711u. The key is to find what they support and what is being used when the call is fine and matching the phone to use the same.


#7

Thank you guys! I don’t see g711u I see g729 A/B, g723.1, g722 wide band, OPUS, iLBC and PCMU and PCMA
Callers say that my voice cuts off, sounds robotics which sounds like packets are lost.


#8

pcmu = g711u


#9

Thank you!
Also should UDP 5060 be forwarded to the phone Ip address?


#10

Ideally yes, but it depends on what you have set for the local SIP port as well as the RTP ports. This is not a cause as if 5060 is not being delivered, then the call would never connect. However, if you control the router, it is best to assign a static IP and/or make a reservation for the phone IP so that it does not move. Then forward your local SIP port and local RTP port (range?) to the the same IP. Also, insure that any SIP ALG is disabled.


#11

I forwarded the SIP port which is 5060 RTP is 5004, still the same.
What is SIP ALG is that in the router setup?


#12

yes…in the router.


#13

I connected the phone with a straight cable to the ISP modem and the same thing is happening. I think this is something with the settings of the phone and Zaplee. I have a softphone that works fine and my received calls are good quality


#14

where is the softphone, how connected?


#15

the softphone is installed on my computer on the same network


#16


#17

posting my speedtest with the jitter


#18

Can you copy the softphone settings into the 2170? Cab you do a packet capture in the 2170 of a call and PM it to me?


#19

I copied manually as much as the settings match on the grandstream 2170. I have x-lite softphone. Is there another way to copy settings? Packet capture with RTP or without?


#20

This is a brand new phone I just purchased. Could this be the actual phone?