Calling IP:PORT on doorbell push no longer functions


#1

Just upgraded firmware to 1.0.7.7 and now calling to an IP:PORT doesn’t work. I had an IP:PORT and a SIP number in the “Number Called When Door Bell Pressed” field. The IP:PORT was to send a signal to a home automation system to ring the doorbell. We noticed that the doorbell was no longer ringing. After some testing and using wireshark on the mirrored switch port of the GDS3710 I discovered:

-a SIP number by itself works fine. SIP INVITE is sent and the call goes through.
-with IP:PORT in that field nothing is sent.
-with IP:PORT,SIP# in that field nothing is sent.
-with SIP#,IP:PORT the SIP INVITE is sent and the call goes through, but nothing is sent to the specified IP:PORT.

When I installed 1.0.7.7 I saved the configuration data, reset the unit, and restored the configuration data.

I’m thinking of downgrading to a previous firmware to see if I can get this functionality again.

Can anyone confirm or disprove this behaviour?


#2

It work for me. GDS clearly sent call to specified ip with port.


#3

Thanks for the reply. This is what I have:

It does the SIP call “103” correctly, here’s the invite:

But there is nothing to 192.168.1.16 after the SIP call to 103.

Settings are:
Call mode : SIP Number
Call Account: Auto
Doorbell mode: Call Doorbell Number
Doorbell call mode: Parallel Hunting
Number called: 103,192.168.1.16:7000,
Enable Direct IP Call: checked
Enable two-way SIP calling: checked
Account 2 enabled with SIP transport set to UDP

I was going to trying doing a downgrade, but I can’t find previous firmware for the GDS3710 on the Grandstream site.


#4

Ok need test as i used only IP call not with SIp earlier.


#5

Ok, after trying many combinations of IPs and Ports and GDS3210 parameters, I gave up and used the COM1 hardwired connections. Too bad; this unit did send the UDP signalling info before, not sure why it stopped working.


#6

@rds: Did you hear “long beep” after press the door bell button of GDS3710? If old firmware working good, what is the firmware version? You can always open support ticket to “helpdesk.grandstream.com” to get old firmwares.

I tested with IP:Port call and it is working fine with me for the 1.0.7.7 and 1.0.7.8 firmware. Just need to make sure the callee (video phone in my case) NOT using random port in the configuration and the related account “active” checked (videophone case the “active” will be checked otherwise it will reject the call and make this not working)

If you have wireshark packet trace, please upload here so we can take a look. Again, you can always open a ticket in Grandstream Support via the "helpsdesk.grandstream.com’ portal to get help from support.

Thank you for using GDS3710!


#7

Yes, heard the long beep on door bull button push. No, it’s not a random port. The related account is active and it makes calls to SIP numbers, just nothing for an IP:PORT call.

I included the wireshark trace for the SIP call above. There isn’t anything to show for the IP:PORT call because nothing happens; there is no wireshark output to show. I also tried enabling the debug info from the GDS sending it to a debug log server but didn’t find this helpful.

Haven’t tried 1.0.7.8 as it’s still beta, but I will once it’s out of beta.


#8

Yes, you can try 1.0.7.8 once it out of beta. But I don’t think 7.7 and 7.8 have any change in the SIP part.

Once thing I can suggest is put the IP address of the 3rd party control device into “white list” for the account port you used. Say if you are using 5062, put into whitelist of Account 2; or just put the IP into whitelist of all four SIP account. I knew the latest firmware enhanced the security to only allow opening door in the whitelist to avoid spam or ghost calls (old firmware cannot do this), but I am not sure because I don’t have your setup or 3rd party device. So try this and see what happens and advise your result.

Thank you for using GDS3710!


#9

@rds: Also, please make sure the call mode is “SIP Number” instead of default “virtual number”. Please advise the result. Thanks and good luck!