Caller ID name in history?


#1

The caller id shows the person’s name when they call, as it should. But when scrolling through the history, it’s all just numbers. Is there any way for it to show the caller ID name as well? GXV3275 phones. Thanks!


#2

For incoming calls, my GXV3275 shows al the names.

The only names that do not appear on mine are the ones for outgoing calls, which is normal.

For outgoing internal calls that the phone updates the CID after the call it’s answered, the CID name should stay in the history. It doesn’t.


#3

I am having a similar issue and it is simply related to the number fomat, i.e. the numbers I am syncing from Exchange are in the canonical address format ( e.g. +49 (89) 123456789 ) but the incoming calls are in the local fomat (e.g. 089123456789).
Is there any way I can either get the phone to match the numbers correctly or to save incoming calls in the canonical format in the history?

The only other option I have is to reformat the numbers, but I really don’t want to do that, as it doesn’t make much sense to move away from the format that works on any device I use except the Grandstream phone.


#4

I think this is an issue that has never properly been solved. On my GXV 3275, the caller’s name is shown on incoming calls - because it is provided by the IP PBX (central phonebook). When I dial a contact from the phone book, the name does only appear as long as the phone number does not contain any blanks or other characters. This has been flagged several times but obviously not fixed yet.

  • bka

#5

Hi, I just bought GXV3370 and face the same issue regarding numbers in canonical format. I am unable to dial from the contacts imported from Gmail account. The phones dials literally the number instead of translating it in a number string. I trieds with a numerical contact number and a second issue occured: if I use “0” in dial plan, all numbers will be prefixed by 0 even internal ones