Caller ID Digital Trunk


#1

I have just had my PRI installed 12 channel with 59 phone numbers. I am trying to get each ext to show up as its own Number. However when calling from that number it still come sin as the primary number. I have gone into ext. and set caller id to the other number. I then went into the trunk setting and unchecked keep trunk cid but it still shows up with the main first number.


#2

tried to create the DOD?
see if you can find anything interesting here:


#3

Yeah I had come across the DOD and set that up as well. Still not working caller ID only shows main number. I would think the DOD options takes place no matter what?


#4

I don’t know how you set it up, try publishing screens


#5

Thanks Again,
I think it is only those 3 screens that matter or maybe I missed something?


#6

Ask provider for format u need use.
It can be different from what you write.

Also remove CallerID number on extension as DOD will not work if that is set.


#7

Thanks it was the provider that was causing the issue/ Adjusted there settings and working now.


#8

@electravis, you put the “solution” in the wrong answer, so it’s as if you solved it yourself :slight_smile: