Call Waiting Tone Does Not Work With More Than 1 Handset Parallel Mode


#1

I have some DP750 base stations set up and I’ve come to find out that the call waiting tone is not heard on the DP720 handset when there is more than 1 handset registered to the base. I have tried to factory reset the base and reconfigure it, but still have had no luck with the tone.

I am on the lastest firmware (1.0.4.2)

I will be contacting support directly tomorrow.

Thanks,
Mike


#2

Bug, i have same with 1 customer. Not sure why this happens (logs not help much as this is handset problem as far i know). It is not happening on all units so i cannot replicate this local.
Please provide me ticket (pm) so i can include this in my ticket and maybe push more for fix (it is already high priority) but we have problem with debug :frowning:


#3

Here is the latest from Grandstream:

"Mike,

I have confirmed that the Call Waiting tone in Parallel Mode is only designed to initiate when all handsets are occupied. The system treats the handset that is not in use as an available line, so the CW tone will not initiate.

Regards,"


#4

That’s not sure, did you tried the option at Profiles x -> Call Settings -> “Enable Call Waiting in Parallel Mode”, set it to “Enabled”, you will hear the call waiting tone for the second handset.


#5

Tried everything. Does not work. Grandstream support stated that this is a future request at this point.

Thanks,
Mike


#6

The option of "“Enable Call Waiting in Parallel Mode” is especially implemented to resolve your issue. I just tested it’s working fine on my device. After set it to “Yes”, for example, if you have 5 handsets in parallel mode using same account 1001, if HS3 is on the call, when another incoming call comes, the HS3 will have new call prompt on the GUI with call waiting tone, you can select to answer it or reject it, if you answer it, you will put your current call on hold. If you reject it, it will keep ringing on other phones until timeout or someone picked it up, or be rejected by all.


#7

Perhaps @mcmac21 can post the Grandstream ticket number so that @Shawn-GSSupport424 can followup with the tech who handled your issue.


#8

Does not work. When I have 2 handsets registered to the same line, with all the correct settings enabled, I cannot hear a call waiting tone when the 2nd call comes in. You can hear the other handset ringing, and if you look at the handset you are on, you can see there is another call coming in. There is no audible indication (call waiting tone) that lets the person know there is a call waiting. Call waiting tone can be heard if the 2nd handset is not registered the the base ( i.e. turned off)

Ticket # is : 20181004174337

Thanks,
Mike


#9

Hi Mike,
Please check this video at:
https://drive.google.com/file/d/1yjNf091YIdz2X-yfeFKC08rmCifApi_E/view?usp=sharing

I assume the audible call waiting tone you mention is exact the one in the video, not a normally speaker ring.

Here is my configuration:


#10

I requested access to view the video from icc*****1@gmail.com


#11

https://drive.google.com/file/d/1yjNf091YIdz2X-yfeFKC08rmCifApi_E/view?usp=sharing
sorry, I changed the access policy, you should able to access it via this link now


#12

No worries and thanks.

So that ringback tone I’m hearing when you walk away is the Call Waiting Tone?

I will test again post pictures + a video.

Thanks,
Mike


#13

wait, i think there are some issue, the call-waiting tone indeed not working.
The tone in the video actually is the audio from the first call, there are other handsets playing the ringtone on speaker, this voice be picked up by the first call caller who is very close. I thought it’s a call-waiting tone but actually it’s not, I just tried a normal call-waiting tone on a HSx mode account, the call-waiting tone is definitely different than the one in my video. So that’s not call-waiting tone, but normal ringtone from other handsets.

I will file a bug and notify SW team fix it ASAP. thanks for letting us know the issue and sorry for the inconvenience.


#14

Thank you for clarifying,
Mike