Call transfer using MPK does not work


#1

Hi, am I missing the trick here… I configured one of the MPKs as mode=“transfer”, value is the taget extension. When I transfer to this extension manually (using transfer button), it works fine. However when I accept the call and then press the MPK, I get a “pause” icon for half a second or so, but call is not transferred.

– bka


#2

Hi Boris,

  1. in Settings > " Virtual Multi-Purpose Keys Settings" you have to set “Transfer Mode via VPK”
    e.g. to the value"attended transfer".
  2. Then set “Enable transfer via non-Transfer MPK” to “yes”
  3. Then set the Physical Multi-Purpose Key to “BLF” and put in the internal extension number as value.

Afterwards you can just press this BLF key and the active call is put on hold, the other extension rings and if he picks up you can talk to him.
If you hang up then the call will be transfered.

You also have the possibility to hang up immediately after pressing the BLF key without having a talk to the participant you want to transfer to.Then it´s handled as a blind transfer - even if “Transfer Mode via VPK”
is set to the value"attended transfer"

In my opinion it is the smartest way to do a transfer at all.

If now it would be possible to get a 3-way conference by pressing the conference button if the first caller is on hold and I talk to the participant I first wanted to transfer to - it would be nearly perfect - but this doesn´t work until now…

All this works without using the transfer button…

Regards Michael


#3

Goodness, this looks a bit weird to me… not the most intuitive way!

Nevertheless, thanks a lot, it pointed me towards the right direction. So, after some testing:

  • using BLF mode does NOT work for me
  • NO need to enable “transfer via non-Transfer MPK”
  • BUT it does only work when I set transfer mode to “attended transfer”

So in essence, transfer using an MPK does NOT work in “blind transfer” mode but it does with “attended transfer”. Which I think is a bug.

Thanks
– bka


#4

Please create a bug report with Grandstream


#5

Well it might be a bug…
But what do you think is weird and not intuitive?
That´s the way most phone systems act like here in germany.

It depends on how many buttons you want to press to transfer a call.

Our clients are used to press 1 button and then hang up to transfer.
Can it be more simple like this?

You don´t have to tell the customer you first have to put the call on hold with this button and then you have to push this button and if you want to transfer you have to push this button afterwards.

I simply press the BLF to which number I want to transfer to and can either hang up imediately for blind transfer or speak to the person who´s on the phone and then hang up to transfer.

So you don´t have to set this strict to blind transfer and you don´t have to choose via button which mode you want.

Can transfering a call be done easier or faster like this?

Regards Michael


#6

Hi Boris,
For I could not believe that blind transfer does not work with BLF key I had a try and
changed the option at " Virtual Multi-Purpose Keys Settings" and set “Transfer Mode via VPK”
to the value"blind transfer".
Leaving the other options as descibed in my first post.
I have to say: It works as well…
If I press the BLF key the other phone (in my case a WP820 but it should´t matter which phone)
rings and the GRP2614 hangs up imediately.
FW is 1.0.0.31
Regards Michael