Call Forwarding Softkey on GRP2616 not showing


I have a GRP2616 provisioned by GDMS on a UCM63xx. I cannot find a way to get the Call Forwarding Softkey to display.

Has anyone found a way to do this?


do you mean a BLF key that allows you to activate / deactivate the forward, consequently display the red / green led if the forward is activated / deactivated?

If you’re looking for this doesn’t exist on GS phones, I’ve been reporting this serious shortcoming for years.


No. I mean the softkeys below the LCD display.

On a GXP2170 the Call Forward key displays. On the GRP2160 it does not.

I need it to display.


Hi David,

I have one 2616 in use programmed via GDMS, the ForwardAll softkey is showing. I don’t have many settings on it, just the virtual and physical keys programmed. Everything else is default. Firmware


I updated the firmware but that did not help.



I honestly never mess with the softkey settings. I leave all those as default. I would factory reset the phone and let GDMS pick it up again and see what happens. You have never adjusted anything on the local gui?
This is how mine is currently set and that’s how it looks on the Idle screen.


Yup. Mine looks the same. And I tried a factory reset as well.

No joy.


Try enable or disable local call features on the phone. Also filling in the feature codes on that same page.
Each will give a different softkey. Eg “call fwd all” or “features”.


I have found that I need to activate Local Call Features on the phone in Account 1 for the softkey to show up.

I also found that this softkey will only work on Account 1, irrespective of this setting on the other accounts or on which account is the active account when it is pushed.

I have reported this behaviour to Grandstream as I feel this softkey should work on all the accounts and I should be able to have the phone only use the server functions vs the local ones.