[BUG] Certificate limited to 2048 chars

bug

#1

Via the web UI, we can’t save the SIP TLS certificate. I get this:

My certificate is from 3CX Pro.


#2

We will fix this ASAP, thanks for reporting!


#3

Please note as of 1.0.7.5 it is NOT fixed.


#4

Yes sir, 1.0.7.5 is mainly for the new GUI and Push to Talk feature, and new model support of DP752/DP730. We will add a lot of bug fixes and new feature in next release.


#5

Hello,
Do you know how long the 3CX Pro SIP TLS certificate could be? we are working on this right now


#6

Here’s how long is mine, so I guess a 4096 chars would be enough. However, it seems to include both the CA and the TLS certificates. (There’s 2 “–BEGIN/END CERTIFICATE–”)


#7

Also, please note that this also affects the 1.0.9.127 of GXP21xx firmware. I get the same error.

The private key works in both.


#8

Also please know that on my GXP2170, I am unable to save the TLS Certificate and Private Key.

I mean it saves, but then I go back and it isn’t there anymore. I tried multiple times, nothing. FW: 1.0.9.127


#9

We have fixed this issue on DP, next official release should include this fix. As for GXP, I will forward this post to GXP team to look at.


#10

Excellent! Keep me posted on the GXP please. 3CX are working on implementing SIP TLS auto provisioning so they will need this to be fixed.