BUG - Blind Transfer (DECT TO DECT) is actually working as Attended. Fw. 1.0.13.0


#1

Hello,

I have 4x DP720 DECTS paired to a DP750 Base.

If I choose to transfer a call blind to an other DP720 (DECT TO DECT - Without SIP) it actually acts like an attended transfer, calling the other DECT first and then giving me the option to transfer.

If I choose to transfer it anyway, then the call transfers but the other DECT cannot hear or speak to the other end 9/10 times.

If I choose to transfer the call the attended way, it’s not showing me the DECTS.

Is there any fix for that bug?


#3

So what you are saying is that on your DP750/720 setup, when you BLIND transfer an incoming call to an other DECT (no SIP account), the call is transfered directly without any other input from you.

Is that correct?


#5

Correct.

Now, what I’m saying is that when I blind transfer a call to an other DECT it actually makes an attented call and not a blind transfer.

Also I am not transfering to extensions but to an other DECT (no sip).


#7

I don’t have any reason not to trust what you’re saying, but here you can clearly see that when I blind transfer the incoming call from the mobile phone it actually initiates an attended transfer between these two DECTS.

Firmware 1.0.13.0 on 750/720


#9

I opened a ticket and they already told me that what I want is not possible.

You cannot blind transfer between headsets without sip accounts. You can only blind transfer between sip extensions.

And yes, there is a bug in the UI of the headsets if they call this blind transfer but it’s actually an attended.

If you have a problem with the word “bug” you can replace it with any other word you like. Maybe something like a false advertising?

This should be clear in the features / manual and fixed asap.


#11

I literally said on my first post I have no SIP accounts on each dect.

You don’t know how to read.
Mystery solved.


#12

If there is no SIP connection, who do you actually want to transfer?
Internal callers?
So is the dect system only used as a better walky talky?
GS will certainly not make any changes to this, as this is not normal use of a DECT system


#13

There is obviously a main SIP account (provider) in the Profile for inbound and outbound calls.

There are no sip (extensions) for each DECT.

Anyway problem is considered solved. I’m going to make different accounts in my pbx.


#15

Then don’t try to solve my problem or tell me that it’s my fault or I don’t know how to configure it.

You kept telling me that you have the same setup and yours is working like I’m the stupid guy in here with the wrong config, while our setups are not the same after all.

I don’t have to apologize to you. You had the attitude right from the start. I thanked you in my other topic and you were very helpful indeed.

Stop replying to my topic or any other I may make in the future, I’m not paying you to be my IT and I don’t need your advice.

Thank you, problem is considered solved.


#17

exactly


#18

I think @grandgrand is refer Intercom calls which does not need SIP account registered.
Actually, you can receive an incoming on a handset that has a SIP account, then transfer the call to another handset that has no SIP registered. This is supported on 1.0.13.0 and 1.0.13.2.

We do have some issue for Intercom in 1.0.13.0, we mistakenly allow to blind transfer a call to a handset using Intercom, while our designed logic does not allow this, and the blind transfer behaves as attended transfer anyway, so we removed the “Blind transfer” option and always use attended transfer in 1.0.13.2 when comes to Intercom.

@damiano70, this feature is kind of advanced, you are right, this is not supposed to be on an VOIP phone, it looks like a walkie talkie, but, DP7xx now even support Push to Talk, which can be exactly a walkie talkie if you choose to not subscribe any SIP service, hehe


#19

I just re-enacted the whole thing with 1x DP720 and 1x DP730 on a DP752 DECT basis.
1 SIP profile, 1 SIP account (HS mode parallel).
Handset Line settings: Line 1 calls HS1 and HS2.
All devices have been updated to the current Beta 1.13.2.
For me it is like this:
1.If I try to initiate a blind transfer from the menu, I will not be offered the other handsets that have been booked in. This means that neither blind nor attended transfer is possible here.
2.I try the route immediately via Attended transfer, I get the internally registered devices to choose from, scroll down, go on “call” - the device is called, then I consult the person I want to connect to and then transfer the call , then it works and the conversation channels are available on both sides.
3. However, if I try to initiate the same route as described in 2 via “hold”, then go to attended transfer and select the device to which I want to connect and initiate the call with “call”, then the menu offers to scroll down to the waiting participants to be able to connect this with a blind transfer.
If you choose this, the blind transfer seems to work.
However, if the called party answers in this scenario, then he is connected to the subscriber, but the speech path is missing on both sides.
I hope the translation is reasonably understandable :slight_smile:
There is clearly a software bug here.
The device list should be available for both blind and attended transfer (if it is already offered for the attended version, then it should also be available for the blind version).
And if it’s offered, it should work.
So clearly a bug or an unfinished feature.


#20

Thanks for the testing.
I know what you mean, in case 3, if you already have 2 active calls, and one of them is Intercom and is “Hold” status, you select to another normal SIP call and use the “Transfer” button, it will immediately transfer it to the Intercom, it looks like blind transfer, but it actually is attended transfer, because the Intercom is already answered, it’s just been held, and to the Handset, it attended.

In 1.0.13.2, you can still do blind transfer, but if you enter the blind transfer option, you will not see the HS listed there. We currently only support attended transfer, the blind transfer will make it a little buggy and complex, so we could revisit this feature later when we got time. Thanks!


#21

Yes, even if I transfer the call the way you did it neither participant can hear the other one on my setup too.


#22

hi @Shawn-GSSupport424,
I wanted to see if you were prepared :stuck_out_tongue: