Bria Mobile and NAT dropping calls


#1

Hi everyone,

I have a problem here with Bria Mobile that I still can’t fix and I know a lot of people here use this app so maybe someone can help me!

I have a remote worker who has a GXP2140 programmed in STUN mode to connect remotely to the office. When I am at my desk and I answer a call from my GXV3370, everything does well.

Although, when I take the call from my Bria Mobile app, I just can’t hear or speak so the call just drop. This happens ONLY when I am on Wi-Fi (on the same network as UCM). My guess is that the NAT is freaking up because since Bria uses Push, their server is connected to the UCM, and the call just goes in and out of the office.

Example:

  1. Incoming Call - Remote (Worker)->Local (UCM)
  2. Ringing Bria - Local (UCM)->Remote (Bria Push Server)->Local (My App on Wi-Fi)
  3. Answering - Remote (Worker)->Local (UCM)->Remote (Bria Push Server)->Local (Bria App)

I think packets are lost with that much NAT traversal. But when on LTE, this doesn’t happen because the call isn’t resent inside the network after going to the Bria servers.

Anyone has an idea? I’m pretty sure it has something to do with my Bria config but I can’t be sure of what is supposed to be the exact config for a UCM working locally and remotely.


#2

In Bria, what are you using for the SIP server address of the UCM, the public or private?


#3

I am using the external FQDN as the “Domain”. I tried using the IPv4 address but it didn’t register.

Also, there’s an “Outbound Proxy” but I am not sure what to put there.


#4

One of the issues of “location awareness” in that the softphone is getting a local IP from the Wi-Fi and then using the external FQDN to reach the UCM, but the softphone is using its recently acquired private IP as the Contact. The UCM is likely responding back to the IP and port as seen in the INVITE which is then never seen by the softphone.

I could be wrong, but I don’t think push has any bearing unless using cellular data (4g Lte or other).

You can -

  1. Get your IT folks to investigate implementing hairpinning
  2. Get your IT folks to investigate using a split-DNS whereby the same FQDN as your external is used, so that when you are on the Wi-Fi, your device will query your local DNS server and resolve to the internal address of the UCM rather than the external. When out of the Wi-Fi, it will use a public DNS and resolve the same FQDN but now to the public IP.
  3. Switch the server IP back and forth as needed.
  4. Only use cellular.

#5

I am using Meraki networking equipment and my DNS is not internal. How can I make my router redirect to the local IP when on the network?

Also, I can’t use only cellular, most of the time I am at the office but not at my desk. By the way, I am the IT guy and I am asking for help because this is driving me nuts.


#6

I do not believe Meraki supports local LAN DNS so read this and see:


#7

I have tried the solution in that forum but it didn’t work.

Bria still connects from outside because of Push Notifications.


#8

Well, my best suggestion is to get with Bria as they know their product far better and have surely encountered similar.

One of the others in this forum may know more about it, but likely faster contacting Bria.