Bellcommander and Contact Header


#21

I don’t have one around, will a USB work? I was getting ready to go over and look at the machine. If it will work, do I just plug it in and then it will show up?

Also, if the USB will work, will it warn me if it is large enough to backup to?

Thanks.
Scott


#22

be sure you do the updates in order, don’t skip to the end unless you are doing a fresh install.


#23

I had read that I needed to go to 1.0.17 and then to 1.0.18. I am on 1.0.14, so you are saying I need to do 15 and 16 also? I am just about up to that on the video and then went over and plugged in a USB HDD to see if it was recognized, but either the system does not recognize it or else I have to tell it that it has one somewhere. Looking for that now.
Scott


#24

Every firmware says the same

Backup your data including configuration before firmware upgrade is recommended.
For UCM6xxx on 1.0.15.x or 1.0.16.x, please upgrade to 1.0.16.20 directly.
For UCM6xxx on firmware earlier than 1.0.15.x, please upgrade to 1.0.15.16 first, then upgrade
to 1.0.16.20. To upgrade to 1.0.15.16, please check 1.0.15.16 release note “Important Upgrading
Note” section and follow the instructions

Every firmware says be on the previous one before upgrading.

The idea is that you may miss a change that was potentially applied in the one you skipped this throwing your system off in a way that could take hours to figure out.

If you just straight to the last one and then do a factory reset then it doesn’t really matter because you are starting fresh.


#25

Will do. I don’t want to do anything before I get a complete backup though. I am always paranoid. I don’t guess the Grandstream likes USB HDDs since it is not showing up, unless I can actually SSH into it and mount the drive. Surely I am not supposed to do that though. I may have to run to another town and pick up an SD later if this does not work.

Scott


#26

I haven’t had any issues with usb HDs. They should work fine. I have put them in straight out of the box as well as after a windows system formats it.


#27

I talked to the company that installed that and he said that it had been finicky with different HDDs. Some worked and some did not so he always used SD cards. I’ll get one after school today and try that.
Scott


#28

Is there some way to tell how big the backup will be? I tried a regular USB stick yesterday afternoon and it took it. Then it tells me the drive is not big enough. It is only 4GB, but I would not have thought it would have taken that much for a backup. We have maybe 60 phones and only two of us have voicemail. I even unchecked the Voice and Fax and still not enough room.
Scott


#29

Each backup should be less than .5 GB(1/2). You made sure it was on USB as its destination instead of Local?


#30

Yes I did. I just ran home and got a 32GB one I had. Backup ran for 5 minutes probably, then suddenly I am logged out. I log back in and click Maintenance->Backup and it just freezes there and does not go to the backup screen. This is typical for me. If it should be easy, it will not work and take me 5 days! :slight_smile:

EDIT: Another 5 minutes and I am still locked out of backup, I guess because it is still doing something. Holy moly.

EDIT2: I am up to about 20 minutes now and I still cannot click on Backup and get in because it is still running I guess. It will give me the “Wait or exit page” after a bit. This is a bit nuts.

Scott


#31

Up to 4.8GB so far. Is the Data Partition supposed to be completely full like this?

Scott


#32

SCOTT! There’s your answer(Takes a deep breath before speaking really fast…)

So basically you’ve saved something locally that should not have been, probably call recordings or voicemails. (it would take a lot of voicemails to fill that).

What’s happening–When you do a backup and check all the slots, it takes all of those recordings and saves them to the USB from the local drive.
Each time you do the backup it is attempting to copy that data from local to the usb.
If you’ve done this 3 times it will have 2GB transfered 3 times, so 6 GB.

If your local drive is full, I guarantee there are other things being affected. ie: Voicemails not saving or emailing, faxes being lost, calls acting suspicious, perhaps even a ring tone not making it through, etc.


Having said that, if I’m right, this is what you need to do:

-start by rebooting the UCM, this will cancel the backup and give you the ability to look at things.(skip if you already can navigate)

-deleting or moving all data off the usb so you can start clean

-Verify what has consumed your local drive. (probably recordings)
–I’d check CDR–>Recording files–>local and see if it is full of recordings.

If so, go to recording storage location and change it from local to USB. It will ask which files you’d like to move to the new location and save. If you don’t care about the recordings just uncheck all the boxes and let the system save the new location. If you move the files it could take 5-15 minutes.

-Once all data is safely where you want it, in recording section of the CDR, delete all local recordings. This should free up your local storage.

-Once you’ve maxed out your local storage there is a high possibility you have corrupted/messed up something on the OS. Firmware upgrades should correct this. !Backup First!


-Now that your local is clear you do a backup of everything and save it to the USB(this one won’t take as long)
When you back up recording files and both the backup and the recording files are already on the USB, it doesn’t do it again. It just references where they are thus taking much less time and space.
–At present you are doing a backup and it is taking the recording files from the local and saving them over every time.

-Once you have a valid backup do your firmware upgrades one by one, with a backup in between each one.
-Last time this happened to me it took 3 firmwares to correct the bugs I was having. But they did correct.

Let me know if you need assistance with any of this as we are here to help!


#33

Thanks for the reply. I can navigate as long as I don’t try to go to the Backup Tab. I guess it is still running and if I go there it hanges. I may let the district know that I am going to reboot it so that I can get to work on this. I was guessing it was maybe voicemails or such taking that partition up, but then I thought maybe this system is different the a regular computer and a full partition is the way it should be.

Now I am curious why the company that put the system in did not have external storage on it?

Thanks for the reply and sorry to be such a pain. This is all new to me and with no training, it is a learning experience. :slight_smile:
Scott


#34

Scott

That’s why I’m here. If we can’t help each other out, what’s the point!
We’re here if you have questions.


#35

I am lost. I don’t even have a local on there and it says it is storing to USB. I just put that in a bit ago, unless there is a slot on the back of the ssytem also. I’ll have to walk over and look.

EDIT: Okay, I got back to this finally. I clicked on that top bar and when it goes to the next screen, it has “Enable Auto Change” selected. I’ll assume that when I stuck the USB in, it switched to that because of that mark.

Scott


#36

Correct.

The drop down must have been added in a newer firmware.
I’d confirm if you can delete all recordings or if they should be saved.

If you can delete them, pull the usb and go look again, it should revert back to local and let you delete them.

if you need to save them, still pull the usb, download all recordings, then delete them.


#37

Well, there aren’t but about 40MB worth of Voice there. I’ll go browse around and see where else you can find stuff taking up storage.

EDIT: I’ll retract that. Yeah, when I changed it ot local, it has a bunch. :slight_smile: I just assumed since it switched, it moved it over.

Scott


#38

It won’t ever “move” anything, it just copies. then you have to delete the old.


#39

Let me ask you this. Isn’t the “Callee” whom it is recording for? If so that is really strange. There are actual telephone numbers on there and not extensions. Numbers that are not here. I am wondering if this thing is set to record all calls now. I thought we had that turned off, but maybe they didn’t.

EDIT: Wow! Yeah, must be a setting somewhere to record everything. I just clicked on one that was really long and it was a conference call from our Bookkeeper on a training that she had. I definitely don’t want to be keeping every single phone call. I would not mind to have button to push in case an admin got an irate parent and needed to record it, which I believe is legal in Missouri since only one person has to know about it and since the one recording does know about it, that satififies the rule.

Scott


#40

Look at Auto Record under each VoIP Trunk. If selected, all calls are recorded.
.
It can also be set to do this at the Extension Level - Features - Auto Record