ATA813 fxo PROBLEM


#22

thank you very much marcin :smiley:


#23

If this is true, and I have no reason to doubt Marcin, then it is really sad that THE primary function of the device has a bug that prevents its use.

I bought one last week to test, but have not gotten around to it as am out of town. I have been using the 503 for 911 calling in hotels and others where they wanted local 911 rather than e911.


#24

Yeah that surprise me to as it almost same from http page. (we still have some 503 :smiley: )
I will talk with GS, maybe there is magic option which is needed now for forward.
Debug was clean, it does do nothing. PSTN work as FXS ring, then i turn it off and … nothing :slight_smile:


#25

I have bought a lot of all products and I have problems with this 813 and I still do not want to use 813 in customer projects.
But as you said, 503 is a good alternative, but it also has issues like interrupting


#26

It’s very interesting that there’s no complete configuration in the product guide file.
I think the company has been aware of this problem but has not been notified.
In this case, just we can restore all the purchased products or wait for the new firmware.


#27

Nah, they not aware or new fw not yet released. This is new product so some bugs are expected (i hate current release model when all companies send beta on market).


#28

Ok, some good news.

  1. If you register account (FXO) it works.
  2. will test with some new firmware IP transfer.

EDIT
2) New firmware transfer also IP.
So just need wait a moment for new fw release.


#29

yes my fxo is register . ok i`m waiting for new firmware .
thank you marcin


#30

Hi marcin
how are you ?
do you know when the new firmware will be generated?


#31

Sorry no idea, it is tested now. So i guess soon ?


#32

Update: new beta should have it fixed.


#33

Hi all, I am new this forum, many greetings to all.
I experienced same trouble I read about in this post, I see Marcin got it working but mention a beta firmware, on site today just new release 1.0.1.2 is available and don’t solve problem.
I try’d many test configuration but forever no success, no log in SIP traffic nor packet from Wireshark analysis.
HT813 FXO forever is unregistered and irresponsive.
AS from your test When ring thru FXS is selected incoming call is detected.
User/administration manual seems incomplete and too many detail about option are unclear or omitted.
Only way to get registered is to configure on PBX as extension but FXO need a trunk, in my test bench never got a way to get trunk registered.
Asterisk report monitored but not registered:


After update of firmware nothing changed and still same dead device remain there.
Are some secret caveat GS hide to configure this to place and answer PSTN call from Asterisk PBX?
I placed a ticket to GS, answer where useless and they asked me to leave them access to network. I cannot do that on weekday and after some reflection I don’t wish at all open my customer network to an unknown person.
Best regards and thank you all for support.
Roberto


#34

I am aware account is disabled otherwise disturb traffic on old PSTN analog PBX
I just can do test and enable during office closure hours.


#35


#36

Update, after setting again call then reboot as I read from another post incoming call from PSTN reach PBX TRUNK then traverse stack to final destination.

Still No way to have it registered, I set again place call if not registered to yes and registration to NO.
No way to place a call on PSTN.

outgoing peer:
transport=udp
host=192.168.1.210:5062
insecure=invite,port
qualify=yes
username=1002
type=peer
secret=***********
port=5062
dtmfmode=rfc2833
context=from-trunk
disallow=all
allow=alaw&ulaw&g723

Update:
Incoming call and CLI wher transferred on few calls then again doesn’t work again. Unmonitored then on answer deliver wrong packet.
Please can some one share a working setup on both PBX and HT sides?


#37

hi Roberto
I’m using beta version of firmware and it is working good.
but i didn’t use latest version yet .
can u give me a remote control to check this problem on your system?
in my idea your problem is on your server side .


#38

Hi Sinaprv, I can for a very limited time on this afternoon, I live in Italy and to do this I have to move to my customer. Now I am at location.

With server side you identify Asterisk?
Trunk is active as you can see and has stable connection to SIP provider.
So before to create an hole to network, I seen a lot of user got troubled with HT813 over different PBX and to commercial too.
NOne shared what they do to get HT working and documentation lack too much in how setting behave.
I own two unit, one was never unpacked due first failed so badly.
I opened a ticket to GS and also them asked to open netwrk. NOw is the time to ask why open network at risk of intrusion when just a simple instruction can solve this threat.
Anyway reading forum, HT8xx series seems bugged and GS firmware is far far away from unit I bought and I worked with since long time ago.
I check this forum later, now I have to work on some infrastructure to solve some production troubles.
Regards
Roberto


#39

hi again , yes you are right HT813 had a bug on Previous version but in beta version all of them solved. i will send you a configuration file and test it with my config.
give me a your network ip address for HT813 and asterisk server ip plz.


#40

FXO Account MUST be ACTIVE.


#41

Hi Marcin, I am aware of this as I wrote before picture, I cannot leave active due old PSTN still is connected in parallel to old Analog PBX and HT813 tend answer incoming call when unregistered.

I am there to add details about what I discovered till now:
Firmware HT813 was defective, after some try I discovered a bug to FreePBX too, both VOIP and PSTN stopped working. Watching in details I figured config file got corrupted after too many attempt to config HT.
No way to reload, I left old trunk in place disabled and wrote a new one. (next step I try clean DBASE and config or better I try import extension on a clean config.

Messagenet VOIP restarted work from forbidden state. (routed to phantom trunk with name scrambled from both trunknames).

SIP packet now come from HT but this new threat wasted a lot of time and I finished scheduled time in a short while.

ChanSip doesn’t work with HT, PJSIP seems better, no way to register in first attempt, incoming PSTN calls where routed to Trunk, stop test for now.

Actually FreePBX crashed down after 30 day ticking like a charm.
I am far away from location so I am waiting someone to restart it and see what happened to.

I cannot test during working time, I cannot risk too much when I am far from location.
I argue next step be on saturday or on test bed over backup unit.
Regards
Roberto