Api-make_call POPUP Not working on GXP 21xx Series


I understand the desire, and I can understand why you feel it needed. Whether or not the pop-up is designed to be a confirmation of each command execution or a confirmation about granting access to a particular phone, I am not sure.

However, given that click2call does not seem to interact with the remote control settings at all, makes it a moot point at present. I am not saying that remote control and click2call should not interact with one another, but until they do, a pop-up of any type does not seem possible.

I will be back in the office today and will play with it to see if I can get any reaction from the remote control functionality. While I think it may be a bug, I am not really sure as the documentation is pretty light on the purpose of the pop-up and how the interaction is supposed to work.


damiano, the popup will/should occur on the phone, not the browser. The browser will receive a response to the request of success or failure.


I understood that, I’m looking for a valid CTI tool.


Ok, I was able to get the popup to show itself. As I suspected, it is a confirmation about allowing remote control. It does not show the number you want dialed.

However, it seemingly has a timeout to the popup in that if you fail to answer yes or no, it will then assume yes after the timeout and dial anyway.


I’ve done several rehearsals, and that popup I’ve never seen


I have never seen this popup, but this is basically what Id want. Would be great to confirm number but this would be fine!


The issue is that once you grant the access, it appears that it is granted for the device IP you allowed until such time as a reboot or other occurs on the phone.

My string:
Settings -


Hello, We are new to Grandstream VoIP. Can you please point us in the right direction to set up placing calls from the URL to the GXP2160? Phones are connected to a UCM6208. We see all these references to http://X.X.X.X/cgi-bin/api-make_call?phonenumber=XXX&account=0&login=admin&password=XXXX, but nothing about the setup required for it’s use. Thank you.