Android GS Wave - No incoming calls while idle

ip-communications

#1

Hello!

No incoming calls while phone’s idle?
It is a missing funcionality, bug or misconfiguration?

Samsung Galaxy S5
Android 6.0.1 Marshmallow
GS Wave 1.0.2.20

Thank you all…


#2

You need to enable NAT Traversal/Keep-alive to keep the connection (ports to be precise) open. If not then when the PBX sends a call to the app, the call will be blocked by a firewall/router of the mobile carrier.

Also using a random port in the app is recommended, but I believe it is already a default setting.


#3

I have the same problem on Xiaomi remi note 7 and Xiaomi mi max. The softphone is ringing only when it is on foreground. If not, no sound, no popup. If you pull down the notification bar, you can see it ringing, and if you press it and swipe right, the ringing screen appears and starts ringing.

The NAT traversal is by default keep alive. I have the latest version.


#4

Please do not post more than once about the same issue and then declare that I have exactly the same issue. The other pots is regarding iPHone whereas you have an Android and the issue is not the same. I am closing the other post so as to keep the issue on track.

The fact that you can “see” the phone ringing by using the notification bar indicated that the call is indeed reaching the phone, which was not the case with the iPhone.

The issue you describe sounds more like a Android setting with regard to the notification for the app and not the app itself, although I could be wrong.


#5

to see if the problem is on your mobile phone model, can you try putting the same settings on GS Wave but on another mobile phone?