7664 Usage Data Missing


Hello everyone

I was wondering if it was just us or have anyone else noticed this.
We have 2 units 7664 and one 7664LR, but none of them reports usage to GWN Manager.

AP firmwares are latest, Manager also. Tried to remember if I noticed this with earlier firmware/Manager versions, but can’t tell for sure



The problem has been known for months, unfortunately Grandstream Support either pretends not to know what it is about or deliberately does not see the problem.
7664 sees ghost sessions, loses usage information under certain environmental conditions.
On some devices I have 100 sessions of users who have been away from the hotspot for weeks.
I have been reporting the problem for months. They keep talking nonsense and according to them there is no problem :frowning:
That’s the situation.
The other devices work properly, there is no problem on other models.


I don’t have these problems on my GWN7664LR,
what FW are you using?

I had some problems initially and solved them with a format factory via SSH,
if you want you can try.


AP firmwares are, Manager is, so the latest versions.
Tried couple of things, resetting to factory default being one of them. No changes.

It’s not that big of a deal, I was just wondering if anyone else noticed this. All 3 of our 7664 units work well, two of them are in mesh (as masters/uplinks/whatever this role is called) and 7660s meshed to them work well and report usage, no problem. So, I’m not sure if this is a 7664 or Manager related issue.
As we are using Mikrotik router(s) I have at my disposal their Dude tool which can monitor throughput via different means. SNMP, for example, shows 7664 traffic both via LAN and wireless for all 3 of them.

Regarding actual usage figures in GWN Manager, I’m not so sure that figures shown for other models, although not zero, are very accurate. I’ve tested this couple of times with large file transfers and results are, at best, 50:50.

The only other thing I’ve noticed with 7664, in particular, is that sometimes they take longer to reboot (not after upgrade, standard reboot). But after that they work well.

Thanks for the answers people


I didn’t mention the simple format factory, but I had written the format factory done by SSH


That did the trick!
Performed a ‘Factory reset’ via SSH console on all 3 7664s, they are now reporting usage to the Manager.

That being said, what could be the idea behind the fact that SSH factory reset, a software function, is more powerful (or at least more thorough) then the factory reset button, a hardware feature, installed specifically and solely for that exact purpose!?

Thanks Damiano70


I can only make assumption…to start with: both are software resets (obviously).

Might be that factory reset just sets all settings to factory default, while the reset through SSH also clears the settings database and afterwards performs the factory reset.

But again, my assumption (and am very glad I know about the SSH reset option).


Wait few days, it think situation will repeat themselves


Upgraded to fmw on Saturday.
Works, but it is not accurate.


2 days after upgrade.
Statistics is empty again :slight_smile:


for me after format factory in SSH and with latest FW it works correctly



Restarting doesn’t do anything here.
Just unplug the Internet from the switch for 3-5 minutes.
And now HIT. When I insert the Internet plug into the switch again, the 7664 restarts itself to factory settings.
Then everything starts working normally, reports etc.
There is an error somewhere in the software :slight_smile: Gentlemen from China are already looking :slight_smile: