401 Unauthorized response to incoming calls?


#21

I’ll send it to you privately, if you don’t mind.


#22

Vitelity is saying that I’m not sending the Caller ID. I have the DOD set - so it should be. Given the settings I posted - is there something else I’m missing?


#23

Sending WHERE ?
There is 4 or 5 fields that can have CID, depending where it must be setting are different.


#24

Most providers will look for CID in the From field. Some will allow you to select the field - From, PAI, or RPID. When you call your cell phone, what do you get? Do you see anything? What is in the trunk “From User” field?


#25

Vitelity needs the account name in the Trunk’s “From User” field in order to register in real time when the call goes out.

Yesterday I gave up because the customer’s office was open and not displaying Caller ID on outbound calls was causing them real problems. So I just overrode the Caller ID at the carrier level, causing every outbound call from the account to show the same CID. This is not a long-term solution, but the client was getting weary testing outbound calls whenever I made a tweak to the settings.

I have a spare box here in my office and am going to load a backup of the client’s system onto it (registered to different accounts, of course) so that I can see what I can do to correct the problem, and where I can test it myself without disturbing the client’s ongoing business.

I am likely to ask for more help once I get into that. :slight_smile:

I will certainly post the solution when I find it. Thanks for the help thus far!

Mike


#26

Where they want Caller ID is question, not where account name.
Normal you set number in such field. Vitelity must say where and which format they want, it is low chance to guess this (you can read incoming call and try duplicate it).


#27

Good evening, all. Wanted to report what appears to be the solution to this problem, for any other Vitelity users.

I finally got around to setting up the spare box in my office and configuring it so that inbound calls come through one trunk and outbound calls go through another trunk. As noted above the outbound trunk only registers when an outbound call is attempted through the trunk - so the “Need Registration” box is unchecked on that trunk, and the user’s ID is placed in the “from user” box.

I set it up identically to the client I was working on above. Called out - caller ID appeared as “unavailable.” I went to the PBX Settings -> SIP Settings -> ToS page and checked the boxes for “Trust Remote Caller ID” and “Send Remote Caller ID.”

Voila - outbound caller ID is displaying as set in the DoD configuration on the trunk.

I have yet to apply this solution to the original client’s settings . . . I have a busy morning tomorrow and want to set it up on an evening where I’ll be available to tweak it when they open for business. If this doesn’t work on the original client’s “live” UCM, I’ll report back. Otherwise assume it was successful.

Mike


#28

why do you leave empty “from domain”?
inoltre nel trunk prova ad aggiungere PCMA


#29

Probably goes back to my first UCM, when I switched over from an Elastix solution I had been using. I put settings in various boxes until it worked. :slight_smile: So apparently Vitelity takes the user name from a different field for a trunk that stays registered consistently.