3 Sip Trunks on 1 UCM


#1

I have 3 SIP trunks to connect in UCM6304 V1.4A, 2 trunks are from the same provider (Claro Guatemala) and the other trunk is from another provider (Tigo Guatemala). Initially, it only had two trunks from the same provider, that is, the two SIP trunks from Claro Guatemala, one with a pilot PBX 2261XXXX and the other with a PBX 2236XXXX with individual CPEs. When I connect the two CPEs to the router (Mikrotik HEX S) none of the trunks work (no incoming or outgoing calls), but when I connect 1 Claro CPE directly to the UCM and the other trunk to the Router, everything works perfectly. The problem is that I want to have 3 trunks (1 CPE per trunk) connected to the router and with two it doesn’t work, nor with three, I suppose. I need help to be able to configure the router correctly.


#2

The problem is probably in the router. You need to activate NAT.

In your case, I strongly recommend that you use GBMS. You activate it by going to the RemoteConnect section of your UCM63xx settings.


#3

When you say CPE you mean a device that is providing you internet so this is your uplink correct the Mikrotik will get an IP form each CPE correct

cpe1 to Mikrotik port 2 Ip via cpe device
cpe 2 to Mikrotik port 4 Ip via cpe device

how will you 3 sip tunks know which route to use in other words which gateway do you have static routes set up on your Mikrotik.

but from the perspective of your trunks on the UCM it is most likely your provider is seeing private Ip of the minktoik which is given to the Mikrotik via the CPE devices… i.e double NAT

UCM to Mikrotik Nat 1 Mikrotik to CPE Nat2
maybe draw a diagram and give a better explanation but that’s what I think form what I have read and it really difficult when someone says connected to Mikrotik cause these is tons of ways you Mikrotik can be set up


#4

Re: Mikrotik router settings for sip.

There is no problem using a Mikrotik to enable as many trunks as needed on a UCM - I would strongly suggest you go to the Mikrotik reseller that you purchased it from and ask for assistance or guidance.

I have many Mikrotik routers in the field with multiple trunks on them without issue.


#5

Thanks for your replies, the Mikrotik router has been configured and now the 3 trunks are available. I am referring to CPE to the device that provides the telephone service, one device per PBX number. There are incoming and outgoing calls, the problem now is that when dialing from an external number to any of the 3 SIP trunks, the call is hang off. If I call from any of the SIP trunks to an external number, I hear the message “All circuits are busy”
When I had only 2 SIP trunks it worked, but I had to use the UCM in Dual mode connecting one trunk directly to the UCM and the other through the router and it worked fine for me, but when I changed the scenario putting two SIP trunks to the router I had problems and I didn’t have audio, I decided to place the scenario: one trunk to the UCM directly and the other trunk connected through the router and it worked perfectly, now the problem is that I have 3 SIP trunks and at least I must have 2 trunks in the router. I am attaching the scenario that worked and the one that didn’t work (At this time I only had two SIP trunks).




#6

I with try something like this I with rather let the Mikrotik do the routing and take the UCM of dual-mode so the UCM and phone are one network with UCM in switch mode

set masquerade on each egress port of the Mikrotik for each CPE
Also under the Mikrotik firewall ensure sip service is disabled on the Mikrotik


set routes