+1 being added in front of dialed numbers

ip-communications

#1

Saw 1 reference to this in the forum but no actual answer. New Asterisk system, new GXP2160. FW 1.0.7.25. When I dial an external number, while the display says “Calling” the number is as I dialed it. Once the call is answered the display switches “Outbound Call” the number gets a +1 added in front of it and recorded as such in history. Hitting redial will not redial as this is invalid for 10 digit dialing in my area. I have an existing Asterisk system running the same software version, an existing GXP2160 running the same firmware and the +1 is not added nor does it display “Outbound Call”. I have been through the dial plan of both PBX’s and both phones and can find no differences, but something is different. Anyone point me in a more useful direction?


#2

assuming you have the option for the + sign in your outbound rules on your PBX then all you need is to allow it on the phone via: Bypass Dial Plan Through Call History and Directories
see pic


#3

Thank you for your response but that did not help. Since posting, I did another test. I took the new phone from the new system and set it up on my old system. Works fine there. Moving it back to the new system same issue. As far as I can tell, both systems are configured exactly the same but obviously not. I must have misconfigured in FreePBX. For the interim, I added an outbound rule to strip the “1” off until I can find where my mistake is. Going to ask the question over in the FreePBX forum but if anyone here is using FreePBX and has an answer, I would more than welcome that here. Thanks.


#4

@blargent - I know this is a long shot that you see this, but I am having the exact same issue. I tried searching the FreePBX forums for a post you may have put up there, but I couldn’t find it. Did you ever resolve this?