Author Topic: Registering using TLS causes inbound calling to not work  (Read 496 times)

Dan

  • Newbie
  • *
  • Posts: 4
    • View Profile
Registering using TLS causes inbound calling to not work
« on: May 12, 2017, 06:42:29 PM »
I'm running Freeswitch 1.4 and trying to connect an HT-802 running 1.0.3.2 to it with TLS. The HT-802 will register and can make outbound calls, but inbound calls never successfully make the device ring. I've got keep-alive on, and if I switch to UDP the device will ring on inbound calls, but with TLS it is just totally non-functional for inbound calls. Tried this on 1.0.2.7 too, got the same result prior to upgrading to 1.0.3.2.

Registering with TLS works fine from a HT-701, GXP2170, Linphone, CSipSimple, Zoiper, etc.

Shawn-GSSupport424

  • Administrator
  • Hero Member
  • *****
  • Posts: 813
    • View Profile
    • Email
Re: Registering using TLS causes inbound calling to not work
« Reply #1 on: July 11, 2017, 06:03:58 PM »
It might because of the TLS port settings, there is a known bug that TLS will still use 5060 as the SIP port, please set the SIP Primary Proxy as "domain.com:443", the 443 should be replaced with your real TLS port, by default it will use 443.
This has been fixed in our next FW release.

wwoo@sunnywood.net

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Registering using TLS causes inbound calling to not work
« Reply #2 on: July 14, 2017, 03:49:17 PM »
we have the same problem between a UCM6108 1.0.13.14 and GXW4224 1.0.5.16
they work fine together with UDP, but once switched to TLS, all calls going to a GXW extension will end up getting the voicemail only. However, dialing out from those GXW extensions will work.
and registering the GXW extensions under TLS seems to work fine.
any thoughts?

Ondrej Holas

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Registering using TLS causes inbound calling to not work
« Reply #3 on: August 26, 2017, 11:59:07 PM »
This may be a problem with Contact header. Try this with 1.0.3.7 as this version introduces new setting "Use Actual Ephemeral Port in Contact with TCP/TLS" (default is No, set it to Yes). PBX will then send INVITE to the ATA via already established session. (PBX should use already established session anyway in case od TLS, regardless of Contact header, but the behavior differs accross different SIP implementations and variety of NAT traversal settings.)

O.